QQ 咨询
谢谢打赏
微信交流
432

解决使用宝塔安装的swoole扩展,运行项目出现的3个常见问题
时间: 2021-01-19 14:08:14  作者:北桥苏  阅读:(59)

前言:

    常常做东西的时候最不愿搭环境了,所以如果只是用于学习或者一些小项目,我都会选择在服务器上使用宝塔面板。自然swoole也是直接用BT的方式安装,但是呢,最近我写的一个双人对战的五子棋小游戏,在我本机虚拟机上能正常运行。放到之前已经装好swoole的服务器上时(宝塔面板安装的),却接连报错。

 

问题一 :

    那个五子棋联机小游戏的后台使用的是easyswoole,所以我测试性的启动一下。php easyswoole start,却出现 PHP Warning: Module 'swoole' already loaded in Unknown on line 0,重启php fpm也是报这个错。

    根据信息提示,就是swoole扩展已经加载过。所以可能就是php.ini文件中多出了一个extension=swoole.so,所以把多的注释或者直接删掉,最好重启一下php就没有这个错误了。

 

问题二:

    php启动是没问题了,通过命令php -m | less查看PHP安装的扩展中也有swoole。但是铜通过php easyswoole start启动时,又报了一个新的错误。Swoole\Process::__construct() expects at most 3 parameters, 4 given。 错误也指出了文件错误的详细地方,提示是说那个类的构造函数应该是传3个参数,但是现在却传了4个。

    我又回到我虚拟机的环境里的代码,发现没什么异常。导致这种原因的那肯定就是搭建的环境中某个软件的版本原因,首先我先怀疑PHP版本,在我认真比对下,PHP版本一致。后来再看了一下错误,错误的根据是一个swoole的函数报错的。所以这肯定是swoole版本原因,可能是旧版本函数某个参数被去掉了。于是我通过命令查看了swoole版本,php --ri swoole

     果然,我之前的是4.5版本,而现在宝塔上的这个是2.2。所以我就去网上找了很多宝塔升级swoole版本的方法,确实也有很多。试过了一两个后没起效果,于是我把swoole删掉,重新再装一遍。这次我没有按顺序,而是先装swoole4, 然后再装的swoole。最后查看版本竟然成功变成了4.5

 

问题三:

    php easyswoole start启动也没有报错了,于是我就打开了游戏页面。发现两个玩家全都连接不上服务器,单独将ws服务地址请求也连接失败。在放行的宝塔上ws服务端口也显示在使用,那这个是什么原因呢。

   折腾了一阵后,我才想起来阿里云的服务器也有一个安全组配置。所以肯定是那个端口是被阿里云的系统拦住了,只要找到安全组添加一个入站规则然后加上端口。最后重启es,打开游戏页面,可以正常运行了。






用户登录


     QQ登录

我的标签


随机文章

  • MySQL如何做如等级/成色等特殊顺序的排序在涉及商品类的项目时,为了给同一类商品定位,…… 查看详情
  • 解决phpstorm激活码无效或has been cancelled问题PhpStorm是一款商业的PHP集成开发环…… 查看详情
  • 消息队列篇——windows本地搭建RabbitMQ ServerMQ全称为Message Queue, 消息…… 查看详情

友情链接





Copyright© 2016-2021 北桥苏 & 版权所有    赣ICP备16002525号-1
如有侵权、不妥之处,请联系站长的客服并出示版权证明以便删除。敬请谅解! 站长客服联系方式:QQ2652364582